#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s).+? (?<name>.+?) \((?<points>\d+) points?\)\n\n(?<description>.*?)\nEdit\nClone\nRemove\n"
Local $sString = "2. Unit test (2 points)" & @CRLF & _
"" & @CRLF & _
"Test checkCharacter("word", 3).equals("Character 'd' is a letter")" & @CRLF & _
"" & @CRLF & _
"Edit" & @CRLF & _
"Clone" & @CRLF & _
"Remove" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")