$re = '/.+? (?<name>.+?) \((?<points>\d+) points?\)\n\n(?<description>.*?)\nEdit\nClone\nRemove\n/s';
$str = '2. Unit test (2 points)
Test checkCharacter("word", 3).equals("Character \'d\' is a letter")
Edit
Clone
Remove
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);