import Foundation
let pattern = #"(\p{Han}+[\p{Han}\d\. \-。]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
That would probably cost you about fifty bucks...
那大概要花掉你50美元左右 100-200。 and some english
and some more english on a new line.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)