use strict;
my $str = 'That would probably cost you about fifty bucks...
那大概要花掉你50美元左右 100-200。 and some english
and some more english on a new line.';
my $regex = qr/(\p{Han}+[\p{Han}\d\. \-。]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}