import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\p{Han}+[\\p{Han}\\d\\. \\-。]*)";
final String string = "That would probably cost you about fifty bucks...\n\n"
+ "那大概要花掉你50美元左右 100-200。 and some english\n"
+ "and some more english on a new line.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}