re = /(\p{Han}+[\p{Han}\d\. \-。]*)/
str = 'That would probably cost you about fifty bucks...
那大概要花掉你50美元左右 100-200。 and some english
and some more english on a new line.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end