const regex = /(\p{Han}+[\p{Han}\d\. \-。]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\p{Han}+[\\p{Han}\\d\\. \\-。]*)', 'g')
const str = `That would probably cost you about fifty bucks...
那大概要花掉你50美元左右 100-200。 and some english
and some more english on a new line.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}