#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\p{Han}+[\p{Han}\d\. \-。]*)"
Local $sString = "That would probably cost you about fifty bucks..." & @CRLF & _
"" & @CRLF & _
"那大概要花掉你50美元左右 100-200。 and some english" & @CRLF & _
"and some more english on a new line."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")