re = /[_](\d{1,4})[.]/m
str = '1234test.mp3
999test.mp3
12test.mp3
0test.mp3
0test.mp34
test1234.mp3
@test.mp3
/test.mp3
\\\\test.mp3
test_1.mp3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end