#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[_](\d{1,4})[.]"
Local $sString = "1234test.mp3" & @CRLF & _
"999test.mp3" & @CRLF & _
"12test.mp3" & @CRLF & _
"0test.mp3" & @CRLF & _
"0test.mp34" & @CRLF & _
"test1234.mp3" & @CRLF & _
"@test.mp3" & @CRLF & _
"/test.mp3" & @CRLF & _
"\\test.mp3" & @CRLF & _
"test_1.mp3" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")