using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[_](\d{1,4})[.]";
string input = @"1234test.mp3
999test.mp3
12test.mp3
0test.mp3
0test.mp34
test1234.mp3
@test.mp3
/test.mp3
\\test.mp3
test_1.mp3
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}