package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[_](\d{1,4})[.]`)
var str = `1234test.mp3
999test.mp3
12test.mp3
0test.mp3
0test.mp34
test1234.mp3
@test.mp3
/test.mp3
\\test.mp3
test_1.mp3
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}