use strict;
my $str = '1234test.mp3
999test.mp3
12test.mp3
0test.mp3
0test.mp34
test1234.mp3
@test.mp3
/test.mp3
\\\\test.mp3
test_1.mp3
';
my $regex = qr/[_](\d{1,4})[.]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}