import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[_](\\d{1,4})[.]";
final String string = "1234test.mp3\n"
+ "999test.mp3\n"
+ "12test.mp3\n"
+ "0test.mp3\n"
+ "0test.mp34\n"
+ "test1234.mp3\n"
+ "@test.mp3\n"
+ "/test.mp3\n"
+ "\\\\test.mp3\n"
+ "test_1.mp3\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}