re = /(\w{2}).*?\b/m
str = 'You will have to read this carefully before you go step by step and you should read this properly'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result