package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w{2}).*?\b`)
var str = `You will have to read this carefully before you go step by step and you should read this properly`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}