using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w{2}).*?\b";
string substitution = @"$1";
string input = @"You will have to read this carefully before you go step by step and you should read this properly";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}