const regex = /(\w{2}).*?\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w{2}).*?\\b', 'gm')
const str = `You will have to read this carefully before you go step by step and you should read this properly`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);