# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w{2}).*?\b/$1/gm;t' <<< "You will have to read this carefully before you go step by step and you should read this properly"