$re = '/(\w{2}).*?\b/m';
$str = 'You will have to read this carefully before you go step by step and you should read this properly';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;