re = /^(\([A-Z]\([0-9]\)[A-Z]\([a-z0-9]{20,28}\)\))\/?(.*)/
str = '(X(1)S(4142eh3owtmwtoztdvvz45wo))/contact-us'
# Print the match result
str.match(re) do |match|
puts match.to_s
end