$re = '/^(\([A-Z]\([0-9]\)[A-Z]\([a-z0-9]{20,28}\)\))\/?(.*)/';
$str = '(X(1)S(4142eh3owtmwtoztdvvz45wo))/contact-us';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);