import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\([A-Z]\\([0-9]\\)[A-Z]\\([a-z0-9]{20,28}\\)\\))\\/?(.*)";
final String string = "(X(1)S(4142eh3owtmwtoztdvvz45wo))/contact-us";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}