const regex = /^(\([A-Z]\([0-9]\)[A-Z]\([a-z0-9]{20,28}\)\))\/?(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\([A-Z]\\([0-9]\\)[A-Z]\\([a-z0-9]{20,28}\\)\\))\\\/?(.*)', '')
const str = `(X(1)S(4142eh3owtmwtoztdvvz45wo))/contact-us`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}