using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\([A-Z]\([0-9]\)[A-Z]\([a-z0-9]{20,28}\)\))\/?(.*)";
string input = @"(X(1)S(4142eh3owtmwtoztdvvz45wo))/contact-us";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}