package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\([A-Z]\([0-9]\)[A-Z]\([a-z0-9]{20,28}\)\))\/?(.*)`)
var str = `(X(1)S(4142eh3owtmwtoztdvvz45wo))/contact-us`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}