// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\${([\w.]+)*(?::([\w]+))?}").unwrap();
let string = "this is a ${partId} in a sentence
this is a ${param.someId} in a sentence
this is a ${partId:number} in a sentence
this is a ${userId:string} in a sentence
this is a ${param.someFlag:boolean} in a sentence
a ${lotId} and a ${panelId} in a sentence";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}