#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\${([\w.]+)*(?::([\w]+))?}"
Local $sString = "this is a ${partId} in a sentence" & @CRLF & _
"this is a ${param.someId} in a sentence" & @CRLF & _
"this is a ${partId:number} in a sentence" & @CRLF & _
"this is a ${userId:string} in a sentence" & @CRLF & _
"this is a ${param.someFlag:boolean} in a sentence" & @CRLF & _
"a ${lotId} and a ${panelId} in a sentence"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")