use strict;
my $str = 'this is a ${partId} in a sentence
this is a ${param.someId} in a sentence
this is a ${partId:number} in a sentence
this is a ${userId:string} in a sentence
this is a ${param.someFlag:boolean} in a sentence
a ${lotId} and a ${panelId} in a sentence';
my $regex = qr/\${([\w.]+)*(?::([\w]+))?}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}