using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\${([\w.]+)*(?::([\w]+))?}";
string input = @"this is a ${partId} in a sentence
this is a ${param.someId} in a sentence
this is a ${partId:number} in a sentence
this is a ${userId:string} in a sentence
this is a ${param.someFlag:boolean} in a sentence
a ${lotId} and a ${panelId} in a sentence";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}