$re = '/\${([\w.]+)*(?::([\w]+))?}/m';
$str = 'this is a ${partId} in a sentence
this is a ${param.someId} in a sentence
this is a ${partId:number} in a sentence
this is a ${userId:string} in a sentence
this is a ${param.someFlag:boolean} in a sentence
a ${lotId} and a ${panelId} in a sentence';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);