const regex = new RegExp('\\${([\\w.]+)*(?::([\\w]+))?}', 'gm')
const str = `this is a \${partId} in a sentence
this is a \${param.someId} in a sentence
this is a \${partId:number} in a sentence
this is a \${userId:string} in a sentence
this is a \${param.someFlag:boolean} in a sentence
a \${lotId} and a \${panelId} in a sentence`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}