import Foundation
let pattern = #"(\d)(?=(\d{3})+\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1
10
100
1000
10000
100000
1000000
10000000
100000000
1000000000
10000000000
100000000000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)