using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)(?=(\d{3})+\b)";
string substitution = @"$1,";
string input = @"1
10
100
1000
10000
100000
1000000
10000000
100000000
1000000000
10000000000
100000000000
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}