import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d)(?=(\\d{3})+\\b)";
final String string = "1\n"
+ "10\n"
+ "100\n"
+ "1000\n"
+ "10000\n"
+ "100000\n"
+ "1000000\n"
+ "10000000\n"
+ "100000000\n"
+ "1000000000\n"
+ "10000000000\n"
+ "100000000000\n";
final String subst = "$1,";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}