const regex = /(\d)(?=(\d{3})+\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)(?=(\\d{3})+\\b)', 'g')
const str = `1
10
100
1000
10000
100000
1000000
10000000
100000000
1000000000
10000000000
100000000000
`;
const subst = `$1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);