$re = '/(\d)(?=(\d{3})+\b)/';
$str = '1
10
100
1000
10000
100000
1000000
10000000
100000000
1000000000
10000000000
100000000000
';
$subst = "$1,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;