import Foundation
let pattern = #"^.*(\d{10})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1445238051199999999999999"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)