package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*(\d{10})$`)
var str = `1445238051199999999999999`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}