# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*(\d{10})$/$1/g;t' <<< "1445238051199999999999999"