$re = '/^.*(\d{10})$/';
$str = '1445238051199999999999999';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;