use strict;
my $str = '1445238051199999999999999';
my $regex = qr/^.*(\d{10})$/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";