const regex = /^.*(\d{10})$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(\\d{10})$', 'g')
const str = `1445238051199999999999999`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);