# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"abc"
test_str = ("aababcbcd \n"
"http://www.python-kurs.eu/re.php\n"
"Erklärung für die einfache Suche")
subst = "\\1 \\2\\t\\3\\t\\4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.