use strict;
my $str = 'aababcbcd
http://www.python-kurs.eu/re.php
Erklärung für die einfache Suche';
my $regex = qr/abc/mp;
my $subst = '\\1 \\2\\t\\3\\t\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";