import Foundation
let pattern = #"^([[:xdigit:]]{1,4}(?::[[:xdigit:]]{1,4}){7}|::|:(?::[[:xdigit:]]{1,4}){1,6}|[[:xdigit:]]{1,4}:(?::[[:xdigit:]]{1,4}){1,5}|(?:[[:xdigit:]]{1,4}:){2}(?::[[:xdigit:]]{1,4}){1,4}|(?:[[:xdigit:]]{1,4}:){3}(?::[[:xdigit:]]{1,4}){1,3}|(?:[[:xdigit:]]{1,4}:){4}(?::[[:xdigit:]]{1,4}){1,2}|(?:[[:xdigit:]]{1,4}:){5}:[[:xdigit:]]{1,4}|(?:[[:xdigit:]]{1,4}:){1,6}:)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
::
::123
::123:456
::123:456:789
::123:456:789:abc:def:6666
::123:456:789:abc:def:6666:7
123::456
123::456:789
123::456:789:abc
123::456:789:abc:def
123::456:789:abc:def:6
123::456:789:abc:def:6:7
123:456::789
123:456::789:abc
123:456::789:abc:def
123:456::789:abc:def:6666
123:456::789:abc:def:6666:7
123:456:789::abc
123:456:789::abc:def
123:456:789::abc:def:6666
123:456:789::abc:def:6666:7
123:456:789:abc::def
123:456:789:abc::def:6666
123:456:789:abc::def:66666:7
123:456:789:abc:def::6666
123:456:789:abc:def::6666:7
123:456:789:abc:def:6666::
123:456:789:abc:def::
123:456:789:abc::
123:456:789::
123:456::
123::
123::456:789:abc:def:6666
123:456:789:abc:def:6666:7
123::456::abc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)