package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([[:xdigit:]]{1,4}(?::[[:xdigit:]]{1,4}){7}|::|:(?::[[:xdigit:]]{1,4}){1,6}|[[:xdigit:]]{1,4}:(?::[[:xdigit:]]{1,4}){1,5}|(?:[[:xdigit:]]{1,4}:){2}(?::[[:xdigit:]]{1,4}){1,4}|(?:[[:xdigit:]]{1,4}:){3}(?::[[:xdigit:]]{1,4}){1,3}|(?:[[:xdigit:]]{1,4}:){4}(?::[[:xdigit:]]{1,4}){1,2}|(?:[[:xdigit:]]{1,4}:){5}:[[:xdigit:]]{1,4}|(?:[[:xdigit:]]{1,4}:){1,6}:)$`)
var str = `::
::123
::123:456
::123:456:789
::123:456:789:abc:def:6666
::123:456:789:abc:def:6666:7
123::456
123::456:789
123::456:789:abc
123::456:789:abc:def
123::456:789:abc:def:6
123::456:789:abc:def:6:7
123:456::789
123:456::789:abc
123:456::789:abc:def
123:456::789:abc:def:6666
123:456::789:abc:def:6666:7
123:456:789::abc
123:456:789::abc:def
123:456:789::abc:def:6666
123:456:789::abc:def:6666:7
123:456:789:abc::def
123:456:789:abc::def:6666
123:456:789:abc::def:66666:7
123:456:789:abc:def::6666
123:456:789:abc:def::6666:7
123:456:789:abc:def:6666::
123:456:789:abc:def::
123:456:789:abc::
123:456:789::
123:456::
123::
123::456:789:abc:def:6666
123:456:789:abc:def:6666:7
123::456::abc
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}