use strict;
my $str = '::
::123
::123:456
::123:456:789
::123:456:789:abc:def:6666
::123:456:789:abc:def:6666:7
123::456
123::456:789
123::456:789:abc
123::456:789:abc:def
123::456:789:abc:def:6
123::456:789:abc:def:6:7
123:456::789
123:456::789:abc
123:456::789:abc:def
123:456::789:abc:def:6666
123:456::789:abc:def:6666:7
123:456:789::abc
123:456:789::abc:def
123:456:789::abc:def:6666
123:456:789::abc:def:6666:7
123:456:789:abc::def
123:456:789:abc::def:6666
123:456:789:abc::def:66666:7
123:456:789:abc:def::6666
123:456:789:abc:def::6666:7
123:456:789:abc:def:6666::
123:456:789:abc:def::
123:456:789:abc::
123:456:789::
123:456::
123::
123::456:789:abc:def:6666
123:456:789:abc:def:6666:7
123::456::abc
';
my $regex = qr/^([[:xdigit:]]{1,4}(?::[[:xdigit:]]{1,4}){7}|::|:(?::[[:xdigit:]]{1,4}){1,6}|[[:xdigit:]]{1,4}:(?::[[:xdigit:]]{1,4}){1,5}|(?:[[:xdigit:]]{1,4}:){2}(?::[[:xdigit:]]{1,4}){1,4}|(?:[[:xdigit:]]{1,4}:){3}(?::[[:xdigit:]]{1,4}){1,3}|(?:[[:xdigit:]]{1,4}:){4}(?::[[:xdigit:]]{1,4}){1,2}|(?:[[:xdigit:]]{1,4}:){5}:[[:xdigit:]]{1,4}|(?:[[:xdigit:]]{1,4}:){1,6}:)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}