# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([[:xdigit:]]{1,4}(?::[[:xdigit:]]{1,4}){7}|::|:(?::[[:xdigit:]]{1,4}){1,6}|[[:xdigit:]]{1,4}:(?::[[:xdigit:]]{1,4}){1,5}|(?:[[:xdigit:]]{1,4}:){2}(?::[[:xdigit:]]{1,4}){1,4}|(?:[[:xdigit:]]{1,4}:){3}(?::[[:xdigit:]]{1,4}){1,3}|(?:[[:xdigit:]]{1,4}:){4}(?::[[:xdigit:]]{1,4}){1,2}|(?:[[:xdigit:]]{1,4}:){5}:[[:xdigit:]]{1,4}|(?:[[:xdigit:]]{1,4}:){1,6}:)$"
test_str = ("::\n"
"::123\n"
"::123:456\n"
"::123:456:789\n"
"::123:456:789:abc:def:6666\n"
"::123:456:789:abc:def:6666:7\n\n"
"123::456\n"
"123::456:789\n"
"123::456:789:abc\n"
"123::456:789:abc:def\n"
"123::456:789:abc:def:6\n"
"123::456:789:abc:def:6:7\n\n"
"123:456::789\n"
"123:456::789:abc\n"
"123:456::789:abc:def\n"
"123:456::789:abc:def:6666\n"
"123:456::789:abc:def:6666:7\n\n"
"123:456:789::abc\n"
"123:456:789::abc:def\n"
"123:456:789::abc:def:6666\n"
"123:456:789::abc:def:6666:7\n\n"
"123:456:789:abc::def\n"
"123:456:789:abc::def:6666\n"
"123:456:789:abc::def:66666:7\n\n"
"123:456:789:abc:def::6666\n"
"123:456:789:abc:def::6666:7\n\n"
"123:456:789:abc:def:6666::\n"
"123:456:789:abc:def::\n"
"123:456:789:abc::\n"
"123:456:789::\n"
"123:456::\n"
"123::\n\n"
"123::456:789:abc:def:6666\n"
"123:456:789:abc:def:6666:7\n"
"123::456::abc\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.