using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([[:xdigit:]]{1,4}(?::[[:xdigit:]]{1,4}){7}|::|:(?::[[:xdigit:]]{1,4}){1,6}|[[:xdigit:]]{1,4}:(?::[[:xdigit:]]{1,4}){1,5}|(?:[[:xdigit:]]{1,4}:){2}(?::[[:xdigit:]]{1,4}){1,4}|(?:[[:xdigit:]]{1,4}:){3}(?::[[:xdigit:]]{1,4}){1,3}|(?:[[:xdigit:]]{1,4}:){4}(?::[[:xdigit:]]{1,4}){1,2}|(?:[[:xdigit:]]{1,4}:){5}:[[:xdigit:]]{1,4}|(?:[[:xdigit:]]{1,4}:){1,6}:)$";
string input = @"::
::123
::123:456
::123:456:789
::123:456:789:abc:def:6666
::123:456:789:abc:def:6666:7
123::456
123::456:789
123::456:789:abc
123::456:789:abc:def
123::456:789:abc:def:6
123::456:789:abc:def:6:7
123:456::789
123:456::789:abc
123:456::789:abc:def
123:456::789:abc:def:6666
123:456::789:abc:def:6666:7
123:456:789::abc
123:456:789::abc:def
123:456:789::abc:def:6666
123:456:789::abc:def:6666:7
123:456:789:abc::def
123:456:789:abc::def:6666
123:456:789:abc::def:66666:7
123:456:789:abc:def::6666
123:456:789:abc:def::6666:7
123:456:789:abc:def:6666::
123:456:789:abc:def::
123:456:789:abc::
123:456:789::
123:456::
123::
123::456:789:abc:def:6666
123:456:789:abc:def:6666:7
123::456::abc
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}